开始在 Windows 上构建 Flutter Android 应用

系统要求

#

在安装和运行 Flutter 前,你的 Windows 环境必须满足以下要求:

硬件要求

#

你的 Windows Flutter 开发环境必须满足以下最低硬件要求。

要求 最低 推荐
x86_64 CPU 核心数 4 8
内存 (GB) 8 16
显示器分辨率(像素) WXGA (1366 x 768) FHD (1920 x 1080)
可用磁盘空间 (GB) 11.0 60.0

软件要求

#

要为 Android 编写和编译 Flutter 代码,你必须安装以下版本的 Windows 以及所列出的软件包。

操作系统

#

Flutter 支持 64-bit version of Microsoft Windows 10 或更高版本。这些版本的 Windows 必须包含 Windows PowerShell 5 或更高版本。

开发工具

#

下载并安装以下软件包的 Windows 版本:

  • Git for Windows 2.27 或更高的版本来管理源代码。

  • Android Studio 2023.2.1 (Iguana) 或更高版本来调试和编译 Android 的 Java 或 Kotlin 代码。 Flutter 需要完整版本的 Android Studio。

上述软件的开发商为这些产品提供支持。如果需要排查安装的问题,请查阅该产品的文档。

当你在当前版本运行 flutter doctor 的时候,它可能会列出这些软件包的其他不同版本。如果出现这种情况,请安装它推荐的版本。

配置文本编辑器或 IDE

#

你可以使用任意文本编辑器或集成开发环境 (IDE),并结合 Flutter 的命令行工具,来使用 Flutter 构建应用程序。

使用带有 Flutter 扩展或插件的 IDE 会提供代码自动补全、语法高亮、widget 编写辅助、调试以及其他功能。

以下是热门的扩展插件:

安装 Flutter SDK

#

你可以使用 VS Code Flutter 扩展或自行下载安装 Flutter 压缩包,来安装 Flutter SDK。

Use VS Code to install Flutter

#

使用 VS Code 安装 Flutter

#

在使用以下流程来安装 Flutter 前,请确保你已经安装 Visual Studio Code 1.77 或更高版本,以及 Flutter extension for VS Code

根据 VS Code 的提示,安装 Flutter

#
  1. 启动 VS Code。

  2. 打开 命令面板 (Command Palette),按下快捷键 Control + Shift + P

  3. 命令面板 (Command Palette) 中输入 flutter

  4. 选择 Flutter: New Project

  5. VS Code 会提示你在计算机上找到 Flutter SDK。

    1. 如果你已经安装 Flutter SDK,请单击 Locate SDK

    2. 如果你没有安装 Flutter SDK, 请单击 Download SDK

      如果你没有按照 开发工具的必要条件 安装 Git for Windows ,单击该按钮后会导航至 Flutter 安装页面。

  6. 当提示 Which Flutter template? 的时候,请忽略它。可以按下 Esc。你可以在检查完开发配置后创建初始测试项目。

下载 Flutter SDK

#
  1. 当对话框 Select Folder for Flutter SDK 显示时,选择你想要安装 Flutter 的位置。

    VS Code 会打开你默认的位置。你可以选择其他位置。

    请考虑 %USERPROFILE%C:\dev 这样的位置。

  2. 单击 Clone Flutter

    在下载 Flutter 时,VS Code 会弹出该通知:

    Downloading the Flutter SDK. This may take a few minutes.

    下载需要一些时间。如果你怀疑下载被挂起,请单击 Cancel 取消下载后,再重新尝试安装。

  3. Flutter 一旦完成下载, 输出 (Output) 面板就会显示。

    Checking Dart SDK version...
    Downloading Dart SDK from the Flutter engine ...
    Expanding downloaded archive...

    成功后,VS Code 会弹出该通知:

    Initializing the Flutter SDK. This may take a few minutes.

    初始化时,输出 (Output) 面板会显示下面的内容:

    Building flutter tool...
    Running pub upgrade...
    Resolving dependencies...
    Got dependencies.
    Downloading Material fonts...
    Downloading Gradle Wrapper...
    Downloading package sky_engine...
    Downloading flutter_patched_sdk tools...
    Downloading flutter_patched_sdk_product tools...
    Downloading windows-x64 tools...
    Downloading windows-x64/font-subset tools...

    该进程还会运行 flutter doctor -v。此时,请忽略该输出。因为 Flutter Doctor 可能会显示与本次快速启动无关的错误。

    Flutter 安装成功后,VS Code 会弹出该通知:

    Do you want to add the Flutter SDK to PATH so it's accessible
    in external terminals?
  4. 单击 Add SDK to PATH

    成功后会显示通知:

    The Flutter SDK was added to your PATH
  5. VS Code 可能会显示一则 Google Analytics 的通知。

    如果你同意,请单击 OK

  6. 在所有 PowerShell 窗口中启用 flutter

    1. 关闭,然后重新打开所有 PowerShell 窗口。

    2. 重新启动 VS Code。

Download then install Flutter

#

下载并安装 Flutter

#

从归档列表中下载 Flutter SDK 压缩包,将压缩包移动到你想要的位置,然后解压 SDK,以此来安装 Flutter。

  1. 下载以下 Flutter SDK 最新 stable 版本的压缩包。

    (loading...)

    关于其他发布渠道和旧版本,请查阅 Flutter SDK 归档列表

    Flutter SDK 应该会下载至 Windows 默认下载目录: %USERPROFILE%\Downloads

    如果你自行更改了下载目录的位置,那么请将之后步骤中解压指令 (Expand-Archive) 的路径 (-Path) 改为你更改后的路径。如果你需要查找当前计算机下载目录的位置,请查阅 Microsoft Community post

  2. 创建一个文件夹,用于安装 Flutter。

    Consider creating a directory at %USERPROFILE% (C:\Users\{username}) 或者 %LOCALAPPDATA% (C:\Users\{username}\AppData\Local).

    可以考虑在 %USERPROFILE% (C:\Users\{username}) 或者 %LOCALAPPDATA% (C:\Users\{username}\AppData\Local) 中创建一个目录。

  3. 将 Flutter SDK 压缩文件 (zip) 解压到你想要存储的目录中。可以使用以下指令进行解压。

    C:> Expand-Archive `
        –Path $env:USERPROFILE\Downloads\flutter_sdk_v1.0.0.zip `
        -Destination $env:USERPROFILE\dev\

    完成后,Flutter SDK 应该会位于 C:\user\{username}\dev\flutter 目录中。

Update your Windows PATH variable

#

更新 Windows PATH 环境变量

#

help 帮助

将 Flutter 添加到 PATH 环境变量后,才能在 PowerShell 中运行 Flutter 指令。本节假定你在 %USERPROFILE%\dev\flutter 中安装了 Flutter SDK。

  1. 按下快捷键 Windows + Pause

    如果你的键盘上没有 Pause 键,请尝试 Windows + Fn + B

    这将会显示 系统 > 系统信息 的窗口。

  2. 单击 高级系统设置 > 高级 > 环境变量…

    这将会显示 环境变量 的窗口。

  3. username 用户变量 的部分中,找到 Path 条目。

    1. 如果存在该条目,请双击它。

      这将会显示 编辑环境变量 的窗口。

      1. 双击空白行。

      2. 输入 %USERPROFILE%\dev\flutter\bin

      3. 单击选中 %USERPROFILE%\dev\flutter\bin 条目。

      4. 单击 上移,直到 Flutter 条目位于列表顶部。

      5. 顺着打开的窗口依次点击 确认(三次)。

    2. 如果条目不存在,请单击 新建…

      这将会显示 新建用户变量 的窗口。

      1. 变量名 框中,输入 Path

      2. 变量值 框中,输入 %USERPROFILE%\dev\flutter\bin

      3. 顺着打开的窗口依次点击 确认(三次)。

  4. 为了启用这些更改,请关闭并重新打开任何现有命令提示符和 PowerShell 实例。

配置 Android 开发

#

在 Android Studio 中配置 Android toolchain

#

help 帮助

To create Android apps with Flutter, verify that the following Android components have been installed.

  • Android SDK Platform, API 34.0.0
  • Android SDK Command-line Tools
  • Android SDK Build-Tools
  • Android SDK Platform-Tools
  • Android Emulator

If you haven't installed these, or you don't know, continue with the following procedure.

Otherwise, you can skip to the next section.

  1. 启动 Android Studio

    显示 Welcome to Android Studio 的对话框。

  2. 按照 Android Studio Setup Wizard 操作。

  3. 安装以下组件:

    • Android SDK Platform, API 34.0.0
    • Android SDK Command-line Tools
    • Android SDK Build-Tools
    • Android SDK Platform-Tools
    • Android Emulator
  1. 启动 Android Studio

  2. 打开 Settings 对话框,查看 SDK Manager

    1. 如果你已经打开了一个项目,请打开 Tools > SDK Manager

    2. 如果显示 Welcome to Android Studio 的对话框,请单击 Open 按钮后面的 More Options 图标,然后从下拉菜单中单击 SDK Manager

  3. 单击 SDK Platforms

  4. 检查 Android API 34.0.0 是否已经选中。

    如果 Status 栏显示 Update availableNot installed

    1. 选择 Android API 34.0.0

    2. 单击 Apply

    3. 当显示 Confirm Change 对话框时,单击 OK

      显示 SDK Quickfix Installation 完成进度的对话框。

    4. 安装完成后,单击 Finish

      安装最新的 SDK 后, Status 栏可能会显示 Update available。这意味着某些额外的系统镜像可能尚未安装。你可以忽略它然后继续。

  5. 单击 SDK Tools

  6. 检查以下 SDK 工具是否已经选择:

    • Android SDK Command-line Tools
    • Android SDK Build-Tools
    • Android SDK Platform-Tools
    • Android Emulator
  7. 如果上述任何工具的 Status 栏显示 Update availableNot installed

    1. 选择所需的工具。

    2. 单击 Apply

    3. 当显示 Confirm Change 的对话框时,单击 OK

      显示 SDK Quickfix Installation 完成进度的对话框。

    4. 安装完成后,单击 Finish

配置目标 Android 设备

#

配置安卓模拟器

#

help 帮助

要配置 Flutter 应用在 Android 模拟器中运行,请按照以下步骤创建并选择模拟器:

  1. 在你的开发电脑上启用 VM acceleration

  2. 启动 Android Studio

  3. 打开 Settings 对话框,查看 SDK Manager

    1. 如果你已经打开了一个项目,请打开 Tools > Device Manager

    2. 如果显示 Welcome to Android Studio 的对话框,请单击 Open 按钮后面的 More Options 图标,然后在下拉菜单中单击 Device Manager

  4. 单击 Virtual

  5. 单击 Create Device

    显示 Virtual Device Configuration 的对话框。

  6. Category 下选择 PhoneTablet

  7. 选择设备,你可以浏览或搜索设备。

  8. 单击 Next

  9. 单击 x86 Images

  10. 单击需要模拟的 Android 版本系统镜像。

    1. 如果所需镜像的 Release Name 右侧有一个 Download 图标,请单击该图标。

      显示 SDK Quickfix Installation 完成进度的对话框

    2. 下载完成后,单击 Finish

  11. 单击 Next

    Virtual Device Configuration 会显示它的 Verify Configuation 步骤。

  12. 如果要重命名 Android 虚拟设备 (AVD),请更改 AVD Name 框中的值。

  13. 单击 Show Advanced Settings 并滚动至 Emulated Performance

  14. Graphics 下拉菜单中,选择 Hardware - GLES 2.0

    这样就会开启 硬件加速 (hardware acceleration) 并提高渲染性能。

  15. 检查你的 AVD 配置。如果已经完备,请单击 Finish

    想要了解更多有关 AVD 的信息,请查阅 Managing AVDs

  16. Device Manager 对话框中,单击所需 AVD 右侧的 Run 图标。模拟器启动并显示所选 Android 操作系统的版本和设备默认的画布。

配置目标 Android 设备

#

help 帮助

你需要一台运行 Android API level 21 或更高版本的安卓设备,来配置 Flutter 应用在真机 Android 设备上运行。

  1. 按照 Android 文档 中的说明,在设备上启用 开发者选项USB 调试

  2. [可选] 如果要利用无线调试,请按照 Android 文档 中的说明在设备上启用 无线调试

  3. 安装 Google USB Driver

  4. 将设备插入你的 Windows 电脑。如果设备发出提示,请授权电脑访问你的设备。

  5. 检查 Flutter 是否能识别连接的 Android 设备。

    在 PowerShell 中运行:

    c:\> flutter devices

    默认情况下,Flutter 使用 adb 工具所在的 Android SDK 版本。如果要在 Flutter 中使用不同的 Android SDK 安装路径,请设置环境变量 ANDROID_SDK_ROOT 为该安装目录。

同意 Android 许可证

#

help 帮助

在使用 Flutter 之前,按照指南安装所有必要的条件之后,再同意 Android SDK 平台的许可证。

  1. 打开一个高权限(管理员)的控制台窗口。

  2. 运行以下指令启用签名许可证。

    C:> flutter doctor --android-licenses

    如果你在其他时候已经同意了 Android Studio 许可证,该指令将会返回:

    [========================================] 100% Computing updates...
    All SDK package licenses accepted.

    你可以跳过下一个步骤。

  3. 请仔细阅读每项许可条款后,再同意。

许可证问题故障排除

#
如何解决查找 Java 安装错误的问题

你可以遇到了 Android SDK 定位 Java SDK 的问题。

$ flutter doctor --android-licenses

ERROR: JAVA_HOME is set to an invalid directory: /Applications/Android\ Studio.app/Contents/jre/Contents/Home

Please set the JAVA_HOME variable in your environment to match the
location of your Java installation.

Android sdkmanager tool was found, but failed to run
(/Users/atsansone/Library/Android/sdk/cmdline-tools/latest/bin/sdkmanager): "exited code 1".
Try re-installing or updating your Android SDK,
visit https://flutter.dev/docs/get-started/install/macos#android-setup for detailed instructions.

这是由于环境变量 JAVA_HOME 设置方式导致的, flutter doctor 指令就会返回此错误。当你在向 JAVA_HOME 添加路径时,可以在 AndroidStudio 之间的空格处添加反斜杠,或者用引号将整个路径包含进来。切记,不能 同时 这样做。

在合适的 shell 资源文件中查找 JAVA_HOME 路径。

将下面这样:

bash
export JAVA_HOME="/Applications/Android\ Studio.app/Contents/jre/Contents/Home"

改成:

bash
export JAVA_HOME="/Applications/Android Studio.app/Contents/jre/Contents/Home"

不要在 AndroidStudio 之间加入反斜杠。

要加载当前更新后的环境变量,请重新加载 shell。本例使用 zsh 资源文件。

source ~/.zshrc

检查你的开发配置

#

help 帮助

运行 Flutter doctor

#

flutter doctor 指令将检查 Windows 完整的 Flutter 开发环境的所有组件。

  1. 打开 PowerShell。

  2. 要检查所有组件的安装情况,请运行以下指令。

    C:> flutter doctor

由于你选择为进行开发,因此不需要 所有 组件。如果你遵循本指南,指令结果应该类似于:

Running flutter doctor...
Doctor summary (to see all details, run flutter doctor -v):
[✓] Flutter (Channel stable, 3.19.3, on Microsoft Windows 11 [Version 10.0.22621.3155], locale en)
[✓] Windows version (Installed version of Windows is version 10 or higher)
[✓] Android toolchain - develop for Android devices (Android SDK version 34.0.0)
[!] Chrome - develop for the web
[!] Visual Studio - develop Windows apps
[✓] Android Studio (version 2023.1)
[✓] VS Code (version 1.86)
[✓] Connected device (1 available)
[✓] Network resources


! Doctor found issues in 2 categories.

解决 Flutter doctor 的问题

#

flutter doctor 指令返回错误时,可能是 Flutter、VS Code、、连接的设备或者网络资源出错。

如果 flutter doctor 指令返回这些组件中的任何一个错误,请使用 verbose 标志再次运行。

C:> flutter doctor -v

查看输出结果,了解可能需要安装的其他软件或者需要执行的其他任务。

如果你更改了 Flutter SDK 或其他相关组件的配置,请 再次运行 flutter doctor 来检查安装。

开始使用 Flutter 开发 on Windows 应用

#

恭喜你!现在,你已经安装了所有必要条件和 Flutter SDK,你可以开始为 on Windows 开发 Flutter 应用了。

管理 Flutter SDK

#

想要了解管理 Flutter SDK 安装的更多信息,请查阅以下内容。